• Begin your adventure!

    Loading...

  • Join our discord!

    Loading...

  • 65% off EVERYTHING on the store!

    From in-game ranks to private mines, its all on sale!

    What version is this server?

    Concealable

    Helper
    Helper
    Explorer
    The version is almost any version above 1.8, but I recommend one of the newer ones so that everything looks right and shows the right blocks.
     

    Danny

    Server Owner
    Server Owner
    Explorer
    We are a 1.13.2 server, how-ever we support versions below up until 1.8.

    We're looking into 1.14 support :)
     

    MarionPVP

    Helper
    Helper
    Explorer
    The server does have an issue connecting on 1.14.4. but the recommended versions are 1.13.2 and above. I mostly only play on 1.8.9 using Badlion Client /w Optifine.
     

    Nerdish

    Moderator
    Mod
    Explorer
    I as well play on 1.8.9 since I use labymod and it works best for me on that version. Works fine for me.
     

    MarionPVP

    Helper
    Helper
    Explorer
    I as well play on 1.8.9 since I use labymod and it works best for me on that version. Works fine for me.
    tbh I can not stand LabyMod because of some of the features it has. I just use Badlion because it has mods that I actually have use for.